../_images/amdblack1.jpg

Multi Version Installation

Users can install and access multiple versions of the ROCm toolkit simultaneously.

Previously, users could install only a single version of the ROCm toolkit.

Now, users have the option to install multiple versions simultaneously and toggle to the desired version of the ROCm toolkit. From the v3.3 release, multiple versions of ROCm packages can be installed in the /opt/rocm-<version> folder.

Prerequisites

Ensure the existing installations of ROCm, including /opt/rocm, are completely removed before the v4.0 ROCm toolkit installation. The ROCm v4.0 package requires a clean installation.

  • To install a single instance of ROCm, use the rocm-dkms or rocm-dev packages to install all the required components. This creates a symbolic link /opt/rocm pointing to the corresponding version of ROCm installed on the system.

  • To install individual ROCm components, create the /opt/rocm symbolic link pointing to the version of ROCm installed on the system. For example, # ln -s /opt/rocm-4.0.0 /opt/rocm

  • To install multiple instance ROCm packages, create /opt/rocm symbolic link pointing to the version of ROCm installed/used on the system. For example, # ln -s /opt/rocm-4.0.0 /opt/rocm

Note: The Kernel Fusion Driver (KFD) must be compatible with all versions of the ROCm software installed on the system.

Before You Begin

Review the following important notes:

Single Version Installation

To install a single instance of the ROCm package, access the non-versioned packages.

Note: You must not install any components from the multi-instance set.

For example,

  • rocm-dkms

  • rocm-dev

  • hip

A fresh installation of single-version installation will install the new version in the /opt/rocm-<version> folder.

../_images/singleinstance.png

Multi Version Installation

  • To install a multi-instance of the ROCm package, access the versioned packages and components.

For example,

  • rocm-dev4.0.0

  • hip4.0.0

  • kernel/firmware package doesn’t have multi version so it should be installed using “apt/yum/zypper install rock-dkms”.

  • The new multi-instance package enables you to install two versions of the ROCm toolkit simultaneously and provides the ability to toggle between the two versioned packages.

  • The ROCm-DEV package does not create symlinks

  • Users must create symlinks if required

  • Multi-version installation with previous ROCm versions is not supported

  • Kernel Fusion Driver (KFD) must be compatible with all versions of ROCm installations

../_images/MultiIns.png

IMPORTANT: A single instance ROCm package cannot co-exist with the multi-instance package.

NOTE: The multi-instance installation applies only to ROCm v3.3 and above. This package requires a fresh installation after the complete removal of existing ROCm packages. The multi-version installation is not backward compatible.

Note: If you install the multi-instance version of AMD ROCm and create a sym-link to /opt/rocm, you must run ‘Idconfig’ to ensure the software stack functions correctly with the sym-link.